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HyperRESEARCH and Chapter 11 – Mapping Tools 

Chapter 11 discusses some of the varying principles, functions and rationales behind mapping tools where they are 

available in software. Mapping in a graphic sense may relate to theoretical models or simply be a way of stepping back 

from the data to express, visualize and communicate connections that are beginning to be observed. See all coloured 

illustrations (from the book) of software tasks and functions, numbered in chapter order.  

Sections included in the chapter: 

Traditions of mapping 

Specific functions and specialities 

Mapping to express theory 

Expressing links between text passages 

Visualizing co-occurring codes 

Linking concepts 

Layers, creating, hiding and revealing them 

Chapter 11 Exercises: Mapping Ideas and Linking Concepts  

This chapter has discussed many different reasons for mapping ideas and linking concepts and starting points for doing 

so. The ways in which you use code mapping will depend on your analytic strategy (in particular, the direction you are 

working in) and your own preferred ways of working (for example, whether you like expressing ideas visually). 

 HyperRESEARCH’s Code Map lets you create a visual layout of the codes you’re using in your study, and show 

relationships by linking the codes. You can make several maps using different sets of codes to focus on particular area of 

interest. You can also narrow down your study data by filtering to show just the codes you’ve selected in a code map. 

While the filter is active, the reporting and analysis tools show just the filtered set of codess, so you can analyze subsets 

of your study data. 

Exercise 1: Create a Code Map 

Experimenting with mapping tools during the stages of designing your project and devising a strategy for using software 

serves multiple functions. Not least becoming familiar with the mapping tools themselves. Always give a map a 

meaningful name and date stamp it (see Chapter 2 for advice on consistent naming protocols). 

a. Create a code map by choosing Codes > Code Map. A blank code map window appears. 
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b. Use the Action menu (at the right of the window, with a gear icon) to choose “Rename Code Map”. Enter a name 
for your code map, along with a date stamp. (See Chapter 2 for advice on consistent naming protocols.) By default, a 
new code map’s name is “Code Map 1”, but this won’t be very helpful in finding the one you want when you create 
multiple code maps, so choose a name that will let you locate this code map later. 

c. Use the Action menu again to choose “New Memo”, and enter a description of the code map. Describe what you 
will use it for and what its purpose is. 

If you need more space, click outside the memo and then click again to select it, and use the blue handles at the 

corners to make the memo larger. Move the memo to the top of the code map so it’s easy to see. 

d. Use the Add tool to add the codes you want to map. The Add tool is the second tool from left at the top of the 

window, and is shaped like a cross. 

 

To add a code to the map, click the Add tool, then click in the code map where you want the code to appear. Choose 
the code you want to use from the list, then click Select. The code you chose appears in the Code Map window. 
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You can continue adding codes like this, one by one, or add several codes at once. To add several codes at once, 
click each one in the dialog box while holding down the Control key (Windows) or Command key (Mac). If you select 
multiple codes, a box is added for each code. 

d. Use the Link tool (third from left) to link two codes together. First click the Link tool, then click one of the codes you 
want to link together. The code is highlighted, and as you move the mouse, you see a line follow it. Click the other 
code to link the two together with a line. 

Continue to link codes together in whatever pattern you want to explore. You can link a code to one other code, to 
multiple codes, or leave it unlinked. For example, you might link together several codes that are conceptually related 
to a broader code. You can simply link codes that remind you of other codes, and explore the relationship as you 
continue the study. 

e. Use the Select tool (the arrow shape, first from the left) to move the codes around in order to see their relationships 
better. (Notice that the link lines follow the codes as you move them.) If you link codes densely, moving them farther 
apart can make the link structure easier to see and understand. 

Exercise 2: Choose Subsets of Codes to Analyze 

You started using code filters in the exercises for Chapter 9. A code filter is a way of choosing the coding for only certain 

codes to use, and temporarily hiding all other coding in the study. This lets you analyze a particular code, or a group of 

codes, in isolation from the rest of the study data. Code filtering can be a powerful tool in analyzing your data, especially 

when used in combination with the case filtering tools. The analysis and reporting tools work with only those codes and 

cases currently filtered, making it easy to concentrate on certain portions of your data. 

a. Use the Mark tool (the marker shape, fourth from left) to highlight a code for special attention. When a code is 
marked, it turns a bright yellow color that’s visually distinct from other codes in the Code Map.To mark a code, 
choose the Mark tool, then click the code. To unmark a marked code, click it again with the Mark tool. Mark several 
codes that you’d like to analyze separately from the rest of the study. 

 

b. Hold down the mouse over the Mark tool so that the popup menu appears. Then choose “Apply Marked Set to 
Study Window”. 

c. Look at your study window and scan through the cases. You’ll see that only the code references for the codes you 
marked are visible. All your other coding is temporarily hidden. 

d. Choose Codes > Filter Codes > All Codes to cancel the filter and show all your coding again. 

Marking codes by linkage depth 

https://study.sagepub.com/using-software-in-qualitative-research
https://study.sagepub.com/using-software-in-qualitative-research
mailto:info@qdaservices.com
https://study.sagepub.com/using-software-in-qualitative-research


This document is designed to complement your reading of Silver & Lewins 2014: Using Software in Qualitative 
Research: A Step-by-Step Guide, Sage Publications, London rather than as a stand-alone resource. Thanks to Ann 
Dupuis and ResearchWare for contributing. Christina Silver & Ann Lewins © SAGE Publications.  

 

 

Please contact info@qdaservices.com if you intend to use these materials for teaching purposes. Visit the companion 
website at https://study.sagepub.com/using-software-in-qualitative-research  

 

 

You can also select codes to mark based on how closely they are linked to a code of interest. This ability can be quite 

powerful when you want to analyze codes that are related to each other in some way that is expressed in your code map 

and its linkages. 

e. Go back to the Code Map, and use the Mark tool’s popup menu to choose “Unmark All Nodes” to clear your marks. 

f. Use the Select tool (the arrow) to select a centrally-linked code whose closely-related codes you want to analyze. 

g. Use the Select tool’s popup menu to choose “Select Connected”, and enter the depth of link you want to use. (For 
example, to select all the codes that are linked to your chosen code, as well as all the codes that are linked to any of 
those codes, enter “2” to indicate that you want to select two links deep.) All the linked codes are now selected. 

h. Use the Mark tool’s popup menu to choose “Mark Selection”. All the linked codes are now marked. 

g. Use the Mark tool’s popup menu to choose “Apply Marked Set to Study Window”. You can now separately analyze 
all the coding for the set of linked codes you just selected. 

h. When you’re done, choose Codes > Filter Codes > All Codes to get back to using the full set of coding. 

Exercise 3: Enhance the Code Map 

a. From the Action menu (the gear shape), choose “New Memo” to add another memo. You can place memoes next 
to groups or links to annotate them or to make notes to yourself for further work. 

b. From the Action menu, choose “Place Image”, then choose an image file from your study. You can use this ability 
to annotate your code map with visual notes as well as text. If this seems useful, use image-editing software to create 
a relevant image. Or use icons to indicate spots of special interest in your code map. (If the use of the icons is not 
obvious, be sure to add a memo explaining them.) 

c. From the Action menu, choose “Resize Relative to Frequency”. The boxes around each code change size to reflect 
the number of times each code has been used, giving you a visual reference to the code’s groundedness. (If you find 
the effect is not useful, you can return to the standard-sized boxes by choosing “Restore All to Original Size”.) 

Exercise 4: Export and Save a Code Map 

You can export a code map as a bitmapped image in several formats. This image can be placed in a Word document, 

printed, used in a web page, and edited in an image-editing program. You can even use it as a source file in your study, 

and code the code map as an image source. 

a. With your code map in front, choose File > Export Data. 

b. Make sure that “Code Map” is selected in the “Export From Window” popup menu. Then choose the file format you 
prefer. (If you’re not sure, choose PNG.) Click Export and enter a file name. 

c. Open the file to check it. 

Note: Export Data exports only the first page of the code map. If your code map extends farther than one 

page, check the Show Page Breaks box at the bottom left of the Code Map window to see where the page 

breaks are. If your code map extends to multiple pages, click the “Page Size” button at the bottom left of 

the Code Map window, then enter a new page height and width. (For example, if your code map extends to 

cover 2 pages tall and two pages wide, double the page height and the page width so that the whole thing 

fits on a single, larger page.) Now you can export your entire code map as a single page. 

Exercise 5: Visualize Your Code Schema 
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Changing your mind about the physical positioning of codes in the main listing is a common activity (see Chapter 9). It 

can be a useful exercise to visualise the current coding scheme in a map before embarking on making extensive 

alterations to it. This may serve both as a record of the initial scheme, and as a means of thinking about how best to alter 

it. Creating abstract ‘objects’ or ‘shapes’ within the map can act as means of thinking about how to split broad codes into 

more detailed aspects and/or generate broader categories out of a collection of more detailed codes.  

a. Create a code map and name it “Code Schema”. (You create a new code map by clicking the “+” button beside the 
list of code maps.) 

 

b. Add either all your codes, or a subset whose schema you are considering changing. 

c. Link the codes together in a way that makes intuitive sense. Do the codes naturally fall into groups and subgroups? 
Are those the same as whatever groups you may already be using? Or do different groupings suggest themselves as 
you work with the codes? 

d. Select an emerging central or broad code, and mark it and its first-level links, then apply the marked set as you did 
in Exercise 2. Scan the data that now appears. Use the Report Builder (in the Tools menu) to create a report that 
includes Coded Source Data, and display the report so you can get an overview of the data that has been coded with 
your set of codes. Does looking at the coded source data confirm that this set of codes forms an emerging group of 
codes? 

e. Decide whether to change your code grouping in accordance with the code map you made, to make more minor 
changes, to save the code map for later consideration, or to leave the coding schema unchanged. 

Also See in HyperRESEARCH Help 

These topics in the HyperRESEARCH Help and the User Guide may be helpful in completing the exercises for this 

chapter: 

 Analysis: Mapping Code Relations 

 Windows: The Code Map Window 

To find a topic, choose Help > HyperRESEARCH Help and look through the list on the left side of the Help window. 

From here you can go in any direction – in the book Chapter 12 deals with the organization of data for the purposes of 

interrogation. You may already have dealt with some elements of organization via coding or via the case book structure 

of the software. See more in the exercises which follow. 

Ann Dupuis 2014 
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